Autor Tema: GR-LIDA 0.11 - dependencia  (Leído 3331 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Linuxica

  • Calculadora
  • Mensajes: 19
  • País: es
  • Fecha de registro: Agosto 02, 2019, 10:26:41 am
    • Ver Perfil
GR-LIDA 0.11 - dependencia
« en: Septiembre 05, 2019, 18:37:28 pm »
Hola .
Vuelvo a tener problemas, esta vez con la instalación del programa, versión 011, el portátil es una máquina de 32 bits que ya tiene 18 años.
Instalé un sistema linux AntiX,  basado en una Debian Strech y al  ejecutar el deb, me da error de la dependencia libpoppler-qt-4-3. Synaptic  me muestra instalada la libpoppler-qt-4-4 pero no me da opción a instalar la 4-3. .
¿Habría algún modo de conseguir esa  dependencia fuera de los repositorios?
Un saludo y gracias.

Desconectado gatuno

  • IBM Roadrunner
  • ****
  • Mensajes: 1217
  • País: gs
  • Fecha de registro: Abril 11, 2018, 22:45:10 pm
  • eterno aprendiz
    • Ver Perfil
Re:GR-LIDA 0.11 - dependencia
« Respuesta #1 en: Septiembre 05, 2019, 19:11:54 pm »
¿Y no te sale mas a cuenta compilar la ultima version?

https://github.com/Monthy/gr-lida/archive/master.zip

Dependencias:
Código: [Seleccionar]
sudo apt-get install qt5-default qtmultimedia5-dev qtscript5-dev libpoppler-qt5-dev
Y luego desde el directorio de gr-lida:
Código: [Seleccionar]
qmake
make


(+) Les Manley in: Search for the King (Traducción) [Finalizada]
(+) Listado de cracks/fixes que voy haciendo

Una gran virtud que tienen los animales es que no tienen problemas de ego. No se sienten ofendidos, ni superiores, ni inferiores. En resumen, que saben vivir mejor que nosotros.

Desconectado Linuxica

  • Calculadora
  • Mensajes: 19
  • País: es
  • Fecha de registro: Agosto 02, 2019, 10:26:41 am
    • Ver Perfil
Re:GR-LIDA 0.11 - dependencia
« Respuesta #2 en: Septiembre 05, 2019, 20:18:50 pm »
Pensaba que la última versión no funcionaría en una máquina de 32 bits en Linuix, ya que no hay deb  ni binario de ella.
Gracias por el apunte voy a intentarlo a ver si lo consigo.

Desconectado gatuno

  • IBM Roadrunner
  • ****
  • Mensajes: 1217
  • País: gs
  • Fecha de registro: Abril 11, 2018, 22:45:10 pm
  • eterno aprendiz
    • Ver Perfil
Re:GR-LIDA 0.11 - dependencia
« Respuesta #3 en: Septiembre 05, 2019, 22:23:00 pm »
Sisi aunque no haya deb de 32 bits lo puedes compilar en 32 bits sin problema.

A no ser que Monthy diga lo contrario no deberia haber problema para usarlo en 32 bits.

Eso si, bajate la version master ya que corrige un bug de la version 0.12.0 que hacia que en linux gr-lida se cerrara.


(+) Les Manley in: Search for the King (Traducción) [Finalizada]
(+) Listado de cracks/fixes que voy haciendo

Una gran virtud que tienen los animales es que no tienen problemas de ego. No se sienten ofendidos, ni superiores, ni inferiores. En resumen, que saben vivir mejor que nosotros.

Desconectado Linuxica

  • Calculadora
  • Mensajes: 19
  • País: es
  • Fecha de registro: Agosto 02, 2019, 10:26:41 am
    • Ver Perfil
Re:GR-LIDA 0.11 - dependencia
« Respuesta #4 en: Septiembre 05, 2019, 23:48:54 pm »
He bajado la versión del enlace que has puesto,  la he compilado y arranca pero parece que aún necesita  algún complemento que añadir. Lo miraré después del fin de semana, el sistema está recién instalado y es normal que falten  librerías, codecs , etc.  por no hablar de que la configuración de esta distro es bastante rudimentaria. 
Muchas gracias.




Desconectado Monthy

  • Administrador
  • Deep Blue
  • *****
  • Mensajes: 972
  • País: es
  • Fecha de registro: Diciembre 05, 2003, 23:28:25 pm
  • Un naufrago
    • Ver Perfil
    • La Isla del Abandoware
Re:GR-LIDA 0.11 - dependencia
« Respuesta #5 en: Septiembre 06, 2019, 00:54:31 am »
Hola Linuxica
Veo que también estas por aquí :) , mejor usar la versión 0.12.0
Y como bien dice el compañero usar la rama maestra del GR-lida 0.12.0

Si te ha compilado bien pero solo falla al arrancar, puede que sea por la falta de 7-zip ya que lo usa para las actualizaciones de script, themes o importar juegos de DBGL.
Creo que es así.
Código: [Seleccionar]
apt-get install p7zip p7zip-full p7zip-rar
Si sigues teniendo problemas avisa, de todos modos tengo planeado sacar la versión de 32bit del paquete debian.


PD nota: Tengo que hacer un tutorial con las dependencias correctas por si se quiere compilar el GR-lida en linux porque para windows ya esta publicado.

Un saludo.




Lanzador de DOSBox y ScummVM GR-lida y el rss feed

Desconectado Kendo

  • Leecher Pata Negra
  • Administrador
  • Shodan
  • *****
  • Mensajes: 10265
  • País: es
  • Sexo: Masculino
  • Fecha de registro: Marzo 05, 2007, 14:47:05 pm
    • MSN Messenger - -
    • AOL Instant Messenger - -
    • Yahoo Instant Messenger - -
    • Ver Perfil
    • Abandonsocios.org
Re:GR-LIDA 0.11 - dependencia
« Respuesta #6 en: Septiembre 06, 2019, 02:39:55 am »
gr-lida para maaaaaaaaac

Sigue asi monthy eres un crack

gr-lida para maaaaaaaaac

Desconectado Linuxica

  • Calculadora
  • Mensajes: 19
  • País: es
  • Fecha de registro: Agosto 02, 2019, 10:26:41 am
    • Ver Perfil
Re:GR-LIDA 0.11 - dependencia
« Respuesta #7 en: Septiembre 06, 2019, 11:49:44 am »
Monthy, el error era algo relacionado con la multimedia, tal vez sea algún codec o librería, ya digo que el sistema está recién instalado, lo miraré con más detenimiento el lunes porque en fin de semana suelo desconectar.
De todos modos en cuanto saques el deb lo probaré también, soy bastante buena testeando software porque entre que soy bastante despistada y que atraigo a los bugs como un imán al hierro, si algo no funciona aún en  extrañas circunstancias, seguro que me lo encuentro.
Un saludo.

Desconectado Monthy

  • Administrador
  • Deep Blue
  • *****
  • Mensajes: 972
  • País: es
  • Fecha de registro: Diciembre 05, 2003, 23:28:25 pm
  • Un naufrago
    • Ver Perfil
    • La Isla del Abandoware
Re:GR-LIDA 0.11 - dependencia
« Respuesta #8 en: Septiembre 06, 2019, 15:56:20 pm »
gr-lida para maaaaaac

Vale, al ejecutarlo si te da error de qtmultimedia es por la falta de este paquete:
Código: [Seleccionar]
libqt5multimedia5-pluginsPuede que fale alguno más pero es el que más me suena.
no es necesario para compilarlo pero si para usar los códec y demás para contenido multimedia.

gr-lida para maaaaaac
« Última modificación: Septiembre 07, 2019, 00:12:12 am por Kendo »


Lanzador de DOSBox y ScummVM GR-lida y el rss feed

Desconectado Linuxica

  • Calculadora
  • Mensajes: 19
  • País: es
  • Fecha de registro: Agosto 02, 2019, 10:26:41 am
    • Ver Perfil
Re:GR-LIDA 0.11 - dependencia
« Respuesta #9 en: Septiembre 08, 2019, 15:39:00 pm »


Efectivamente, no tenía ese plugin.  :)
Lo malo es que ahora me ocurre lo mismo que ya me ocurrió con la instalación en el XP.


Parece  que aquí también faltan los plugins Qt de la base de datos. ¿Podría ser? El mensaje de error es exactamente el mismo.
« Última modificación: Septiembre 09, 2019, 18:25:29 pm por Linuxica »

Desconectado Monthy

  • Administrador
  • Deep Blue
  • *****
  • Mensajes: 972
  • País: es
  • Fecha de registro: Diciembre 05, 2003, 23:28:25 pm
  • Un naufrago
    • Ver Perfil
    • La Isla del Abandoware
Re:GR-LIDA 0.11 - dependencia
« Respuesta #10 en: Septiembre 09, 2019, 13:58:26 pm »
Perdón por contestar tarde pero ayer desconecte un poco.
Para la base de datos: libqt5sql5, libqt5sql5-sqlite

Estas serian las dependencias: libqt5gui5, libqt5widgets5, libqt5core5a, libqt5multimedia5, libqt5multimedia5-plugins, libqt5multimediawidgets5, libqt5network5, libqt5xml5, qt5-image-formats-plugins, libqt5opengl5, libqt5script5, libqt5sql5, libqt5sql5-sqlite, libpoppler-qt5-1, p7zip, p7zip-full, p7zip-rar, libc6, libgcc1, libgl1-mesa-glx | libgl1, libqt5printsupport5, libstdc++6


Lanzador de DOSBox y ScummVM GR-lida y el rss feed

Desconectado Linuxica

  • Calculadora
  • Mensajes: 19
  • País: es
  • Fecha de registro: Agosto 02, 2019, 10:26:41 am
    • Ver Perfil
Re:GR-LIDA 0.11 - dependencia
« Respuesta #11 en: Septiembre 09, 2019, 22:14:23 pm »
No hay nada que perdonar, sólo faltaría eso después del esfuerzo y tiempo que dedicas a esto y de un modo altruista. 
GR-LIDA ya me arranca perfectamente,  muchas gracias. Tengo ahora un problemita con un juego de ScummVM del que no parece encontrar el path,  pero creo que ese tema ya no corresponde a este subforo en particular y si no lo resuelvo  lo consultaré en el subforo de "No me funciona el juego" o en el de la página de gr-lida, porque el caso es que directamente en ScummVM sí que me funciona.
Un saludo y gracias a todos.